> > > Firefox でFlash とShockwave のプラグインがインストールできない

Firefox でFlash とShockwave のプラグインがインストールできない

Flash Player Plugin とShockwave Player Plugin のインストーラは、インストーラでインストールされたFirefox しか検知できず、Portable Firefox や、フォルダ丸ごと別のPC からFirefox を持ってきた場合などにはプラグインがインストールされず、Flash とShockwave が見られない、という制限があります。

解決策はFirefox のインストーラで上書きインストールしたのちにそれぞれのインストーラでインストールするのが一番カンタンです。あるいは、非推奨かつ自己責任な荒技ですが、Flash とShockwave が正常に動いているFirefox のインストールしたフォルダ直下にある"plugins" フォルダ以下のファイルを全て上書き。Portable Firefox の場合はこうするしかないかも。手元で確認した限りは、一応、動いているようには見えてます。

いくつかの脆弱性をフィックスしたFirefox 1.5.0.7 が09/15 に出ていますので、さくっとアップデートしたついでにこのあたりの動作も確認しておくと良いかも。

動作確認は以下のページで。

Home > PC > Firefox > Firefox でFlash とShockwave のプラグインがインストールできない

Return to page top